Page 30 of 33 FirstFirst ... 202829303132 ... LastLast
Results 726 to 750 of 824

Thread: AeroLib Include

  1. #726
    Join Date
    Jul 2017
    Posts
    3
    Mentioned
    0 Post(s)
    Quoted
    3 Post(s)

    Default

    getCurrenthealth function melts my cpu and getCurrentHealthPercentage aint working correctly for me and this only happened after update and yes i'm using newest simba

  2. #727
    Join Date
    Aug 2007
    Location
    Colorado
    Posts
    7,356
    Mentioned
    266 Post(s)
    Quoted
    1410 Post(s)

    Default

    Quote Originally Posted by pimpalasmanija View Post
    getCurrenthealth function melts my cpu and getCurrentHealthPercentage aint working correctly for me and this only happened after update and yes i'm using newest simba
    Which client are you using?

  3. #728
    Join Date
    Jul 2017
    Posts
    3
    Mentioned
    0 Post(s)
    Quoted
    3 Post(s)

    Default

    Official rs client also tried osbuddy runeloader and konduit

  4. #729
    Join Date
    Aug 2007
    Location
    Colorado
    Posts
    7,356
    Mentioned
    266 Post(s)
    Quoted
    1410 Post(s)

    Default

    Quote Originally Posted by pimpalasmanija View Post
    Official rs client also tried osbuddy runeloader and konduit
    Ok go into 'Login'simba' (AeroLib/Entities/Player/Login) and comment out line 205, 206 and 207 like so:
    Simba Code:
    //{$IFNDEF SMART}
        //activateClient();
      //{$ENDIF}
    Then tell me if that works for you.

  5. #730
    Join Date
    Jul 2017
    Posts
    3
    Mentioned
    0 Post(s)
    Quoted
    3 Post(s)

    Default

    Working again after downgrading simba to older version this was my way to fix it
    Last edited by pimpalasmanija; 12-26-2017 at 12:56 PM.

  6. #731
    Join Date
    Aug 2007
    Location
    Colorado
    Posts
    7,356
    Mentioned
    266 Post(s)
    Quoted
    1410 Post(s)

    Default

    Quote Originally Posted by pimpalasmanija View Post
    Working again after downgrading simba to older version this was my way to fix it
    Which version? I don't know if I ever mentioned it but I recommend using Simba 1.2-rc6 the 32-bit version. I've also had problems in the past with the 64-bit Simba.

  7. #732
    Join Date
    Jun 2012
    Posts
    31
    Mentioned
    0 Post(s)
    Quoted
    20 Post(s)

    Default

    Ever since your update I am getting this error:

    [AL] Initiating AeroLib...
    [AL] Checking version...
    [AL] There's a major update available for AeroLib.
    [AL] Updating AeroLib...
    Error: Corrupt ZIP file C:\Simba\Includes\AeroLib.zip at line 96
    Execution failed.

  8. #733
    Join Date
    Aug 2007
    Location
    Colorado
    Posts
    7,356
    Mentioned
    266 Post(s)
    Quoted
    1410 Post(s)

    Default

    Quote Originally Posted by chambo123 View Post
    Ever since your update I am getting this error:

    [AL] Initiating AeroLib...
    [AL] Checking version...
    [AL] There's a major update available for AeroLib.
    [AL] Updating AeroLib...
    Error: Corrupt ZIP file C:\Simba\Includes\AeroLib.zip at line 96
    Execution failed.
    You'll notice following the 2.1 update I've modified the 5-step tutorial for setting up AeroLib. The auto-updater is disabled and from 2.0+ the users should update manually which involves 5 easy steps (I included pictures). If your version of AeroLib still has the auto-updater enabled then you're horribly out-dated. Follow the tutorial on the OP and let me know how that works for you.

  9. #734
    Join Date
    Jul 2017
    Posts
    31
    Mentioned
    0 Post(s)
    Quoted
    11 Post(s)

    Default

    Flight,

    Im getting back into osrs and botting. update everything switch to aerolib 2.1. Today I ran some of my old scripts and they still worked. Then i downloaded your rune runner lite and tried running and it didnt work. Afterwards i tried running some of my old scripts again, and now they wont walk anyware. I even tried running some basic walk programs and they didnt work ether.

    for example i tried running this basic code and it wouldn't do anything.



    Simba Code:
    program walkerSetup;
    {$DEFINE WALKER}
    {$i AeroLib/AeroLib.Simba}
     var
      pathToRats: TPointArray;
      RSW: TRSWalker;
      t:UInt32;
    procedure setup;
    begin
    initAL;
      WriteLn('Loading World Map...');
      RSW.Init('Includes/AeroLib/maps/WorldMap.png');
      RSW.walkStyle := wsSPS;
      RSW.anyAngle := True;
      RSW.skipClose := 15;
    end

        function checkLocation(): string;
    var
      currentPos: TPoint;
    begin
      currentPos := RSW.GetMyPos();
      writeLn('Current Position: ', currentPos);
      if (currentPos.x > 4750) or (currentPos.x < 4527) or (currentPos.y < 3519) or (currentPos.y > 3719) then
      begin
        writeLn('Out Of Bounds, Going to Lumby...');
        result := 'outofbounds';
      end
    end

    procedure createPaths;
    begin
      pathToRats :=[Point(4696,3573),Point(4726,3573),Point(4741,3574),Point(4747,3539),Point(4729,3524),Point(4706,3508),Point(4659,3491),Point(4618,3496),Point(4601,3523),Point(4593,3552),Point(4593,3561),Point(4592,3597)];
     // ratFailSafe := [[4597, 3630]];
      RSW.WalkPath(pathToRats)
    end

     procedure loaction2;
    begin
      RSW.Init('WorldMap');
      WriteLn('RSW is setup!');

      //The first scan is a lot slower then the next scans, it's used to setup stuff..
      t := GetTimeRunning();
      WriteLn('I am here: ', RSW.GetMyPos(), ' used: ', GetTimeRunning()-t,'ms');

      //scan again.. this time it will be pretty much "instant".. same for all of the future times.
      t := GetTimeRunning();
      WriteLn('I am here: ', RSW.GetMyPos(), ' used: ', GetTimeRunning()-t,'ms');

      //one more time to prove my point..:
      t := GetTimeRunning();
      WriteLn('I am still here: ', RSW.GetMyPos(), ' used: ', GetTimeRunning()-t,'ms');

      RSW.Free();
    end;


    begin
     initAL;
     loaction2;
    setup;
    checkLocation;
    end.
    I then tried to use GaintRatGenocide V2 which is a newer program and it would walk but, it just wouldn't walk me in the right direction at all.
    Last edited by underforu; 01-01-2018 at 09:53 AM.

  10. #735
    Join Date
    Aug 2007
    Location
    Colorado
    Posts
    7,356
    Mentioned
    266 Post(s)
    Quoted
    1410 Post(s)

    Default

    Quote Originally Posted by underforu View Post
    Flight,

    Im getting back into osrs and botting. update everything switch to aerolib 2.1. Today I ran some of my old scripts and they still worked. Then i downloaded your rune runner lite and tried running and it didnt work. Afterwards i tried running some of my old scripts again, and now they wont walk anyware. I even tried running some basic walk programs and they didnt work ether.

    for example i tried running this basic code and it wouldn't do anything.

    I then tried to use GaintRatGenocide V2 which is a newer program and it would walk but, it just wouldn't walk me in the right direction at all.
    Thanks for the feedback. Based off the example script you gave, and also citing a scrip that walks within Lumbridge, I'm gonna go out on a limb here and assume that your walking is inaccurate because currently Lumbridge is plastered with snow which heavily alters the world map for this area. I did not change the Lumbridge area map because the holiday event is only temporary, however if you want scripts that walk within this area to walk properly until the holiday event is removed, I suggest just using RSWalker's map-debugger and gathering the current map chunks of Lumbridge that have snow and splicing them into the WorldMap.

    Now, do you have any other scripts that aren't walking properly that do not walk in a Lumbridge-based location?

  11. #736
    Join Date
    Jul 2017
    Posts
    31
    Mentioned
    0 Post(s)
    Quoted
    11 Post(s)

    Default

    Thanks flight your were right the snow was missing me up. with my old scripts I was loading maps like this

    Code:
      RSW.Init('WorldMap');
    I switch the scripts to

    Code:
    MapRSW.Init('Includes/AeroLib/maps/WorldMap.png')
    and now every thing is working.

  12. #737
    Join Date
    Jan 2018
    Posts
    1
    Mentioned
    0 Post(s)
    Quoted
    1 Post(s)

    Default

    Error: Plugin(AND_TPA32) has not been found
    Compiling failed.
    I get this error when running this.
    Code:
    program RUNME;
    {$DEFINE WALKER}
    
    {$i AeroLib/AeroLib.Simba}
    
    begin
      initAL();
    end.
    I have what I believe to be the latest version of simba and aerolib
    followed all the guides I could find on setting up pluggins and includes to work with osr,
    any help would be greatly appreciated.

  13. #738
    Join Date
    Jul 2012
    Posts
    49
    Mentioned
    1 Post(s)
    Quoted
    26 Post(s)

    Default

    I always get this when i try to Aerolib 1.6 with Hoodzfighter script:

    Code:
    [=================================]
    |        < Aero|Library >         |
    |        ----------------         |
    |         Version  : 1.2          |
    |          Revision : 6           |
    [=================================]
    [AL] Initiating AeroLib...
    [AL] Checking version...
    [AL] There's a major update available for AeroLib.
    [AL] Updating AeroLib...
    Error: Corrupt ZIP file C:\Simba\Includes\AeroLib.zip at line 96
    Execution failed.
    Can i make it so it doesn't create a .zip file in my includes folder?

    I have also tried Aerolib 2.1 since the auto-update is disabled, but i get this error instead:
    Code:
    Error: Operator "cmp_Equal" not compatible with types at line 163
    Compiling failed.
    What can i do to fix this?
    I've tried different version of Simbas, including the latest, but nothing works!

  14. #739
    Join Date
    Jan 2018
    Posts
    1
    Mentioned
    0 Post(s)
    Quoted
    1 Post(s)

    Default

    Hello there. Thank you for the detailed information, however, I keep receiving an error when try tostart the 'OSR Dans barb fishing script'. I dont know what's wrong, but i installed everything above. Would u like to help me ?

    Thanks in advance!

    Following error:
    ----
    [Error] C:\Simba\Includes\AeroLib\core\Constants.simba(61: 18): Semicolon (';') expected at line 62
    Compiling failed.

    ----
    and

    ----
    Error: Unknown declaration "WDx1" at line 264
    Compiling failed.

    ----

    and
    ----
    program JaczBarbFisher;
    {$DEFINE SMART} {add // osbuddy}
    {$i AeroLib/AeroLib.Simba}

    ----

    Using lape or Pascalscript interpreter, All doesn't work
    Last edited by osrscpq; 01-17-2018 at 04:19 PM.

  15. #740
    Join Date
    Aug 2007
    Location
    Colorado
    Posts
    7,356
    Mentioned
    266 Post(s)
    Quoted
    1410 Post(s)

    Default

    Quote Originally Posted by lordofspud View Post
    Error: Plugin(AND_TPA32) has not been found
    Compiling failed.
    I get this error when running this.
    Code:
    program RUNME;
    {$DEFINE WALKER}
    
    {$i AeroLib/AeroLib.Simba}
    
    begin
      initAL();
    end.
    I have what I believe to be the latest version of simba and aerolib
    followed all the guides I could find on setting up pluggins and includes to work with osr,
    any help would be greatly appreciated.
    You're using an out-dated version of AeroLib, as that plugin was discontinued from the library from 2.0 and newer. There's links to the newest version of AeroLib on the OP along with updated detailed instructions on installation.

    Quote Originally Posted by nt4rz View Post
    I have also tried Aerolib 2.1 since the auto-update is disabled, but i get this error instead:
    Code:
    Error: Operator "cmp_Equal" not compatible with types at line 163
    Compiling failed.
    What can i do to fix this?
    I've tried different version of Simbas, including the latest, but nothing works!
    I'm positive this is due to an outdated or incompatible version of Simba. Download this version of Simba, put it in your Simba folder and run it. Give that a try and let me know if it fixes the error.

    Others have come across the same issue that simple over-looked the part where I mention to use this exact version of Simba. As I said in a previous post on another thread, I just fresh installed Simba on a new laptop, used this exact version of Simba and everything is running smooth. So there should be no reason at all for that error if the installation guide on the OP is read and followed.

    Quote Originally Posted by osrscpq View Post
    Hello there. Thank you for the detailed information, however, I keep receiving an error when try tostart the 'OSR Dans barb fishing script'. I dont know what's wrong, but i installed everything above. Would u like to help me ?

    Thanks in advance!

    Following error:
    ----
    [Error] C:\Simba\Includes\AeroLib\core\Constants.simba(61: 18): Semicolon (';') expected at line 62
    Compiling failed.

    ----
    and

    ----
    Error: Unknown declaration "WDx1" at line 264
    Compiling failed.

    ----

    and
    ----
    program JaczBarbFisher;
    {$DEFINE SMART} {add // osbuddy}
    {$i AeroLib/AeroLib.Simba}

    ----

    Using lape or Pascalscript interpreter, All doesn't work
    Alas I couldn't find Dan's Barb fishing script I did find & download JaczBarbFisher. The error here is caused by that script being written in a slightly older version of AeroLib in which constants like "WDx1" (and so on) have been replaced. So to fix that script in particular you would replace this:
    Simba Code:
    mouseBox(toBox(WDx1,WDy1,WDx2,WDy2), MOUSE_LEFT);
    with this:
    Simba Code:
    mouseBox(BOX_WD, MOUSE_LEFT);
    You'll need to make this adjustment in two places, and after that the error will be fixed. There's also another one I noticed which you'll encounter after that, and to fix it you simply replace this line:
    Simba Code:
    windMouseFunc(X, Y, 725+random(8), 414+random(5), 9.0,3.0,10.0/rS,15.0/rS,10.0*rS, @WS_findWorld);
    with this:
    Simba Code:
    windMouseFunc(X, Y, 725+random(8), 414+random(5), 9.0,3.0,10.0*rS, @WS_findWorld);

    Then the script should compile fine for you. But for future reference, if you're having trouble with a specific script you should contact the scripter and explain the issue, as this thread pertains the AeroLib.

  16. #741
    Join Date
    Jan 2012
    Location
    Sydney, Australia
    Posts
    876
    Mentioned
    12 Post(s)
    Quoted
    367 Post(s)

    Default

    Quote Originally Posted by Flight View Post
    You're using an out-dated version of AeroLib, as that plugin was discontinued from the library from 2.0 and newer. There's links to the newest version of AeroLib on the OP along with updated detailed instructions on installation.



    I'm positive this is due to an outdated or incompatible version of Simba. Download this version of Simba, put it in your Simba folder and run it. Give that a try and let me know if it fixes the error.

    Others have come across the same issue that simple over-looked the part where I mention to use this exact version of Simba. As I said in a previous post on another thread, I just fresh installed Simba on a new laptop, used this exact version of Simba and everything is running smooth. So there should be no reason at all for that error if the installation guide on the OP is read and followed.



    Alas I couldn't find Dan's Barb fishing script I did find & download JaczBarbFisher. The error here is caused by that script being written in a slightly older version of AeroLib in which constants like "WDx1" (and so on) have been replaced. So to fix that script in particular you would replace this:
    Simba Code:
    mouseBox(toBox(WDx1,WDy1,WDx2,WDy2), MOUSE_LEFT);
    with this:
    Simba Code:
    mouseBox(BOX_WD, MOUSE_LEFT);
    You'll need to make this adjustment in two places, and after that the error will be fixed. There's also another one I noticed which you'll encounter after that, and to fix it you simply replace this line:
    Simba Code:
    windMouseFunc(X, Y, 725+random(8), 414+random(5), 9.0,3.0,10.0/rS,15.0/rS,10.0*rS, @WS_findWorld);
    with this:
    Simba Code:
    windMouseFunc(X, Y, 725+random(8), 414+random(5), 9.0,3.0,10.0*rS, @WS_findWorld);

    Then the script should compile fine for you. But for future reference, if you're having trouble with a specific script you should contact the scripter and explain the issue, as this thread pertains the AeroLib.
    Is in my signature Flight!

  17. #742
    Join Date
    Aug 2007
    Location
    Colorado
    Posts
    7,356
    Mentioned
    266 Post(s)
    Quoted
    1410 Post(s)

    Default

    Quote Originally Posted by Dan the man View Post
    Is in my signature Flight!
    Ah! On that note, Dan, are you having any issues with your scripts being ran on the current version of AeroLib?

    Updated to revision #1.
    • Global WorldList saving & loading
    • WS_switchRandomWorld() added, utilizing WorldList
    • Login handling for attemping to log into a skill work higher than the player's total level
    • Fixed findSymbols/findSymbolsMulti
    • Login handling for "You're standing in a member only zone"
    • A possible temporary compile fix for users not using the recommended version of Simba


    Nothing major in this update, just some fixes really, however the addition of the WorldList is important as it makes the in-game WorldSwitcher fully functional as well as giving it the ability to choose & hop to a random world, depending on the player's membership status. It's neat how it works, any time a script opens up the world list screen (on the login screen) the WorldList is auto-updated & saved to a text file within the AeroLib folder. Or if you'd like to force an update of the WorldList simple call updateWorldList();. Also calling loadWorldList('P2P'); or loadWorldList('F2P'); will give you a list of of member worlds or free worlds, respectively, while only accessing the WorldList file, removing the need to manually open the world list screen.

    Also, the much needed handling of unrecognized login error messages. This should make for much longer run times assuming your script switches worlds at all. Again, if anyone has compile errors or suggestions they'd like to see in the include, please feel free to post here or contact me directly.

  18. #743
    Join Date
    Jan 2012
    Location
    Sydney, Australia
    Posts
    876
    Mentioned
    12 Post(s)
    Quoted
    367 Post(s)

    Default

    No compile errors besides the Barb script that have been brought to my attention. Would only be errors due to args from pre-AL 2.X which are easily fixed.

  19. #744
    Join Date
    Jan 2018
    Posts
    1
    Mentioned
    0 Post(s)
    Quoted
    1 Post(s)

    Default

    Hello, I'm new to Simba and am having trouble installing AeroLib. My goal is to learn how to script and most of the existing scripts I've found use this, so I'm trying to start off with using it too.

    I'm not sure how to find the plugin dependencies listed "Plugins: SMART 8.5+, RSText, Layer". Running the test script, I get this error "Error: Unknown declaration "dateToStr" at line 448" which I'm guessing is because of the missing plugins. Could someone show me where to find these 3 plugins?

    Thanks

  20. #745
    Join Date
    Aug 2007
    Location
    Colorado
    Posts
    7,356
    Mentioned
    266 Post(s)
    Quoted
    1410 Post(s)

    Default

    Quote Originally Posted by Collin 11 View Post
    Hello, I'm new to Simba and am having trouble installing AeroLib. My goal is to learn how to script and most of the existing scripts I've found use this, so I'm trying to start off with using it too.

    I'm not sure how to find the plugin dependencies listed "Plugins: SMART 8.5+, RSText, Layer". Running the test script, I get this error "Error: Unknown declaration "dateToStr" at line 448" which I'm guessing is because of the missing plugins. Could someone show me where to find these 3 plugins?

    Thanks
    I'd be happy to help. The plugins you're needing are listed on the OP of this thread; you'll find the download link here. The compile error you're seeing is probably due to the fact you're using an older version of Simba. Also on the OP I mentioned you must be using the newest version of Simba, and furthermore a specific, 32-bit version of it. I do indeed list these requirements for a reason.

  21. #746
    Join Date
    Nov 2011
    Location
    England
    Posts
    3,070
    Mentioned
    294 Post(s)
    Quoted
    1093 Post(s)

    Default

    @Flight .zip attachment size limit has been raised to 10mb. You can finally get rid of that awful, slow off-site hosting.

  22. #747
    Join Date
    Feb 2012
    Location
    Norway
    Posts
    973
    Mentioned
    143 Post(s)
    Quoted
    585 Post(s)

    Default

    Let me remind you both that github supports releases where you can upload a .rar file for hosting. It wont be deleted, and results in speedy downloads.
    !No priv. messages please

  23. #748
    Join Date
    Aug 2007
    Location
    Colorado
    Posts
    7,356
    Mentioned
    266 Post(s)
    Quoted
    1410 Post(s)

    Default

    Quote Originally Posted by Olly View Post
    @Flight .zip attachment size limit has been raised to 10mb. You can finally get rid of that awful, slow off-site hosting.
    Perfect! Thanks for the advice, I think I'll make the switch today.

    Quote Originally Posted by slacky View Post
    Let me remind you both that github supports releases where you can upload a .rar file for hosting. It wont be deleted, and results in speedy downloads.
    I did indeed notice that through your own Github account; I believe for RSWalker? I forget. However, thanks for the advice. I've been on the fence about linking the newest AeroLib with the previous Github for 1.6. Time will tell I suppose.

  24. #749
    Join Date
    Feb 2012
    Location
    Norway
    Posts
    973
    Mentioned
    143 Post(s)
    Quoted
    585 Post(s)

    Default

    Quote Originally Posted by Flight View Post
    I did indeed notice that through your own Github account; I believe for RSWalker? I forget. However, thanks for the advice. I've been on the fence about linking the newest AeroLib with the previous Github for 1.6. Time will tell I suppose.
    Indeed, that's how I do releases for RSWalker. It doesn't have to be insync with the repository as you might have spotted in my release-comments. But it's a very good way to do your releases. You get the history of prev releases, and if it's in sync with the repo, you get to browse the source online for the release, and therefor also the changes made since previous release.
    !No priv. messages please

  25. #750
    Join Date
    Dec 2016
    Posts
    9
    Mentioned
    0 Post(s)
    Quoted
    3 Post(s)

    Default

    i updated eveerything and then my aerolib stopped working cant win

Page 30 of 33 FirstFirst ... 202829303132 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 6 users browsing this thread. (0 members and 6 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •