Page 2 of 2 FirstFirst 12
Results 26 to 39 of 39

Thread: [OSR][Color] Glitched Granite Miner V1.12 PUBLIC Alpha

  1. #26
    Join Date
    Dec 2007
    Location
    Middle of Here and There
    Posts
    414
    Mentioned
    6 Post(s)
    Quoted
    25 Post(s)

    Default

    Here's what I got so far today:
    -------------Glitched Granite Powerminer------------
    ----------------------------------------------------
    - Time running: 1 Hours, 23 Minutes and 3 Seconds
    - Exp gained: 40340
    - 31893 exp/hr
    - Current level: 86(3702252)
    - Exp til level: 270042
    - Estimated time to next level: 8 Hours, 28 Minutes and 1 Seconds
    ----------------------------------------------------


    Yes, it has been walking away from the rocks, and I'm still having some issues figuring out how to deal with that. If you take the exit; out of reposition it will go back to the correct spot, almost definitely. I may need to test it more to be sure.

  2. #27
    Join Date
    Dec 2007
    Location
    Middle of Here and There
    Posts
    414
    Mentioned
    6 Post(s)
    Quoted
    25 Post(s)

    Default

    Quote Originally Posted by Curse View Post
    -------------Glitched Granite Powerminer------------
    ----------------------------------------------------
    - Time running: 2 Hours, 48 Minutes and 27 Seconds
    - Exp gained: 64390
    - 25217 exp/hr
    - Current level: 89(4964127)
    - Exp til level: 938704
    - Estimated time to next level: 37 Hours, 13 Minutes and 31 Seconds
    ----------------------------------------------------

    Legitimate rock found. 45.2769256906871 Angle is 55.4077113124901
    TPACHeck passed.
    Taking fire, teleport away!!
    Begin recovery procedure.
    0
    1

    There is my proggy. 2 Issues. For some reason it goes to the wrong spot when walking back to the granite mine. The bigger issue is that sometimes it doesn't refil waterskins properly and walks south so the fountain is off the screen so it can't refill waterskins.

    Changed some things to address these issues. Not sure why it would go to the bottom fountain though o.O unless your compass was facing south or somethin. Anyways, see version 1.31 in first post

  3. #28
    Join Date
    Dec 2007
    Location
    Middle of Here and There
    Posts
    414
    Mentioned
    6 Post(s)
    Quoted
    25 Post(s)

    Default

    Replace the finalPos procedure with this:


    Simba Code:
    procedure finalPos;
    var
      x, y, timmeh, loops, timrr, timyr: Integer;
      uptt: String;
      tpt, tpts:Tpoint;
      TPACheck, temppy: TBox;
      TERP: Tpointarray;
      Colors: TIntegerArray;
      Uptexts: TStringArray;
    begin


      if(ItemInSlot(27)) then
      begin
        for loops := 25 to 28 do
        begin
          if(ItemInSLot(loops)) then
          begin
            tpts := MiddleBox(InvBox(loops));
            Mouse(tpts, 5, 5, Mouse_Right);
            uptt := GetUpText;
            wait(randomrange(150, 350));
            if(pos('2', uptt) <> 0) then
              IncEx(curxp, 60)
            else if(pos('50', uptt) <> 0) then
              IncEx(curxp, 50)
            else if(pos('5k', uptt) <> 0) then
              IncEx(curxp, 75);
            ChooseOption('rop');
          end;
        end;
        //FinalPos;
      end;
      avgrad := 0;
      avgangle := 0;
      //Exit;


      WriteLN('Repositioning');
      SetCompass('n');

      Wlk.WalkPath([Point(4499,4779)]);


      SetAngle(0);
      Colors := [6326696, 7117502, 5470357, 5997731, 6261162, 4349556, 3756646];
      Uptexts := ['ine'];
      loops := 5;
      recovering := true;
      timmeh := getInvCount;
      marktime(timyr);
      repeat
        WriteLN('->Repeat');
        while(not(TPAFinder(False, True, -35, 35, 5, 5, MSCY, MSCX, Colors, Uptexts, x, y, MSBox, TPACheck))) do
        begin
          Inc(loops);
          AntiBan(0, 0, 0);
          if(loops >= 15) then
          begin
            WriteLN('No bueno');
            Wlk.WalkPath([Point(4495,4782)]);
            finalPos;
            Exit;
          end;
        end;
        WriteLN('Treeteet');
        Mouse([x, y], 0, 0, Mouse_Right);
        wait(randomrange(75, 150));
        ChooseOption('ine');
        Marktime(timrr);
        AntiBan(0, 0, 0);
        if(isInvFull) then
        begin
          recovering := False;
          setCompass(230);
          avgrad := 0;
          avgangle := 0;
          Exit;
        end;
        while(not(timmeh < getInvCount) or (TimeFromMark(timrr) >= 9500)) do AntiBan(0, 0, 0);
      until((timmeh < getInvCount) or (TimeFromMark(timyr) >= 20000));
      if((TimeFromMark(timyr) >= 20000)) then
        finalpos;
      recovering := false;
      setCompass(230);
      avgrad := 0;
      avgangle := 0;
    end;


    It's a simple edit, but it helps loads
    Last edited by Probably Glitched; 03-21-2015 at 04:56 PM.

  4. #29
    Join Date
    Feb 2015
    Posts
    35
    Mentioned
    0 Post(s)
    Quoted
    13 Post(s)

    Default

    I have downloaded and tried to run the script but I am now getting a compiling error. @Probably_Glitched



    Also this access violation occurs when I run this version vs .13
    Last edited by Curse; 03-22-2015 at 06:11 PM.

  5. #30
    Join Date
    Mar 2015
    Posts
    23
    Mentioned
    0 Post(s)
    Quoted
    6 Post(s)

    Default

    Quote Originally Posted by Curse View Post
    I have downloaded and tried to run the script but I am now getting a compiling error. @Probably_Glitched



    Also this access violation occurs when I run this version vs .13
    I also got the line 149 error.

  6. #31
    Join Date
    Jun 2007
    Posts
    309
    Mentioned
    0 Post(s)
    Quoted
    84 Post(s)

    Default

    Glitched Granite Powerminer------------
    ----------------------------------------------------
    - Time running: 2 Hours, 8 Minutes and 30 Seconds
    - Exp gained: 54185
    - 25333 exp/hr
    - Current level: *-***** (high 50s)
    - Exp til level: ********
    - Estimated time to next level: this part works

    pming you a detailed report.

    Thank you very much

  7. #32
    Join Date
    Mar 2015
    Posts
    2
    Mentioned
    0 Post(s)
    Quoted
    3 Post(s)

    Default

    Sorry to bother, im having a error.

    Exception in Script: Unable to find file 'AeroLib/AeroLib.Simba' used from 'C:\Users\Ned\Downloads\Glitched Granite Miner v0.131 Alpha.simba'


    Cant figure out whats wrong
    Help appreciated

  8. #33
    Join Date
    Aug 2014
    Posts
    165
    Mentioned
    2 Post(s)
    Quoted
    73 Post(s)

    Default

    Quote Originally Posted by mrlnt View Post
    Sorry to bother, im having a error.

    Exception in Script: Unable to find file 'AeroLib/AeroLib.Simba' used from 'C:\Users\Ned\Downloads\Glitched Granite Miner v0.131 Alpha.simba'


    Cant figure out whats wrong
    Help appreciated
    Get the AeroLib include here.
    Follow the instructions and have fun getting 99 mining!

  9. #34
    Join Date
    Feb 2015
    Posts
    35
    Mentioned
    0 Post(s)
    Quoted
    13 Post(s)

    Default

    I am quite dum. I forgot to set the LoadTheSmart to true. I got this proggy with babysitting yesterday.


    -------------Glitched Granite Powerminer------------
    ----------------------------------------------------
    - Time running: 11 Hours, 10 Minutes and 0 seconds
    - Exp gained: 337870
    - 30257 exp/hr
    - Current level: 89(5295247)
    - Exp til level: 607584
    - Estimated time to next level: 32 Hours, 55 Minutes and 9 Seconds
    ----------------------------------------------------

  10. #35
    Join Date
    Mar 2015
    Posts
    2
    Mentioned
    0 Post(s)
    Quoted
    3 Post(s)

    Default

    Thanks for the quick response,fixed the Aerolib problem.
    Now getting this error

    Exception in Script: Unknown compiler directives at 6:3

    Anybody got info about this please?

  11. #36
    Join Date
    Mar 2012
    Posts
    19
    Mentioned
    0 Post(s)
    Quoted
    1 Post(s)

    Default

    Quote Originally Posted by mrlnt View Post
    Thanks for the quick response,fixed the Aerolib problem.
    Now getting this error

    Exception in Script: Unknown compiler directives at 6:3

    Anybody got info about this please?

    Also having this issue. I might just be dumb but it doesnt look like a normal compiling error :/

  12. #37
    Join Date
    Aug 2014
    Posts
    165
    Mentioned
    2 Post(s)
    Quoted
    73 Post(s)

    Default

    Quote Originally Posted by mrlnt View Post
    Thanks for the quick response,fixed the Aerolib problem.
    Now getting this error

    Exception in Script: Unknown compiler directives at 6:3

    Anybody got info about this please?
    Quote Originally Posted by dogtoy12 View Post
    Also having this issue. I might just be dumb but it doesnt look like a normal compiling error :/
    Are you guys using Lape as your interpreter? If not, switch to it.
    Script > Interpreter > Lape

  13. #38
    Join Date
    Feb 2015
    Posts
    35
    Mentioned
    0 Post(s)
    Quoted
    13 Post(s)

    Default

    Quote Originally Posted by Probably Glitched View Post
    Replace the finalPos procedure with this:


    Simba Code:
    procedure finalPos;
    var
      x, y, timmeh, loops, timrr, timyr: Integer;
      uptt: String;
      tpt, tpts:Tpoint;
      TPACheck, temppy: TBox;
      TERP: Tpointarray;
      Colors: TIntegerArray;
      Uptexts: TStringArray;
    begin


      if(ItemInSlot(27)) then
      begin
        for loops := 25 to 28 do
        begin
          if(ItemInSLot(loops)) then
          begin
            tpts := MiddleBox(InvBox(loops));
            Mouse(tpts, 5, 5, Mouse_Right);
            uptt := GetUpText;
            wait(randomrange(150, 350));
            if(pos('2', uptt) <> 0) then
              IncEx(curxp, 60)
            else if(pos('50', uptt) <> 0) then
              IncEx(curxp, 50)
            else if(pos('5k', uptt) <> 0) then
              IncEx(curxp, 75);
            ChooseOption('rop');
          end;
        end;
        //FinalPos;
      end;
      avgrad := 0;
      avgangle := 0;
      //Exit;


      WriteLN('Repositioning');
      SetCompass('n');

      Wlk.WalkPath([Point(4499,4779)]);


      SetAngle(0);
      Colors := [6326696, 7117502, 5470357, 5997731, 6261162, 4349556, 3756646];
      Uptexts := ['ine'];
      loops := 5;
      recovering := true;
      timmeh := getInvCount;
      marktime(timyr);
      repeat
        WriteLN('->Repeat');
        while(not(TPAFinder(False, True, -35, 35, 5, 5, MSCY, MSCX, Colors, Uptexts, x, y, MSBox, TPACheck))) do
        begin
          Inc(loops);
          AntiBan(0, 0, 0);
          if(loops >= 15) then
          begin
            WriteLN('No bueno');
            Wlk.WalkPath([Point(4495,4782)]);
            finalPos;
            Exit;
          end;
        end;
        WriteLN('Treeteet');
        Mouse([x, y], 0, 0, Mouse_Right);
        wait(randomrange(75, 150));
        ChooseOption('ine');
        Marktime(timrr);
        AntiBan(0, 0, 0);
        if(isInvFull) then
        begin
          recovering := False;
          setCompass(230);
          avgrad := 0;
          avgangle := 0;
          Exit;
        end;
        while(not(timmeh < getInvCount) or (TimeFromMark(timrr) >= 9500)) do AntiBan(0, 0, 0);
      until((timmeh < getInvCount) or (TimeFromMark(timyr) >= 20000));
      if((TimeFromMark(timyr) >= 20000)) then
        finalpos;
      recovering := false;
      setCompass(230);
      avgrad := 0;
      avgangle := 0;
    end;


    It's a simple edit, but it helps loads
    Hey, the script seems to have an issue but I can pinpoint why the issue occurs. It seems to mine for about 5-10 minutes and then just pauses and constantly says repositioning.
    Secondly, I cannot get the script to run for more than an hour. I've tried watching it happen but haven't figured out exactly what the issue is. I've tried to run it consistently all day 24/7 and it seems to log out after about an hourish consistently.

  14. #39
    Join Date
    Mar 2015
    Posts
    13
    Mentioned
    0 Post(s)
    Quoted
    5 Post(s)

    Default

    Capture.PNG i keep getting this error no clue how to fix it, any help?

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •