Results 1 to 17 of 17

Thread: General OSRS info

  1. #1
    Join Date
    Jan 2018
    Posts
    8
    Mentioned
    0 Post(s)
    Quoted
    6 Post(s)

    Default General OSRS info

    Hi there, new user here excited to get try my hand at experimenting with Simba.
    Please forgive me if this is in the wrong section, I didn't see anything in the way of intro section


    Recently I decided that I wanted to learn to code to some extent.
    What that extent is, I am not quite sure yet :P
    However, I used to bot Runescape back before they largely broke up most of the bots.
    I either used paid scripts or RiD which at the time was the best around.
    ( Never wrote my own code. )

    That being said I always heard about Simba/SRL, that if you knew how to use it, it was fantastic.
    Going to read through some more guides and get OSRS re-downloaded on my computer,
    because years later after I stopped caring about Runescape, I want to use it to learn to write code.

    I'm hoping that learning this skill on a game will help make it more interesting/rewarding.

    Is there anything you can recommend to get started on writing?
    I'm going to make a new RS account more than likely. But I would like to know a few things..

    1) I read through a few guides already and a couple linked to pages that explicitly said the OSRS SRL was out of date and not working. So I was surprised to see there was an OSRS section and public bots... Can anyone link a page to a definitive answer for this?

    2) Would it be any easier/different learning to code RS3 vs OSRS code?
    Looking to do the easier of the two for now , because of the mixed messages I got from the guides about OSRS
    I'm sort of assuming that it will be more difficult to handle the OSRS coding?


    If you made it this far thank you so much for reading.
    Appreciate any and all feedback.

    Edit: reading the official/unofficial reflection setup guide now.
    Last edited by keasbey_nights; 01-02-2018 at 06:42 AM.

  2. #2
    Join Date
    May 2012
    Location
    Glorious Nippon
    Posts
    1,001
    Mentioned
    50 Post(s)
    Quoted
    500 Post(s)

    Default

    Quote Originally Posted by keasbey_nights View Post
    op
    Hello and welcome! This is a great place to learn the basics of coding.
    Unfortunately the forums can be a bit slow at times. If you ever need more immediate help, there is always the SRL Discord: https://discord.gg/kXPHJfh

    Here is a great place to start with the basics of Simba: https://villavu.com/forum/showthread.php?t=58935

    Regarding the 2 different games:
    There is an official RS3 include with documentation here: http://docs.villavu.com/srl-6/index.html
    There are a few different includes for OSRS:
    SRL and AeroLib use color, then there is reflection. I have no idea how well the reflection include is being maintained.
    I personally recommend that you learn to script with color

    If you have any more questions, feel free to post them, PM me, or ask on Discord. Enjoy your stay!

  3. #3
    Join Date
    Jan 2018
    Posts
    8
    Mentioned
    0 Post(s)
    Quoted
    6 Post(s)

    Default

    Thank you, and no worries on the forums being slow - will check out discord
    So it is fully doable to code for OSRS , using color ( recommended ) or reflection?

    Will start the installs and making my new RS account ready to go haha.
    Is there anything you guys can recommend specifically in the way of anti-ban?
    Obv. there's no perfect solution, but I would like to be able to get some time out of it account before the account gets burned lol.

    Again it's a new account so I'm not worried about losing wealth or anything ingame. Just curious.

    Thank you for reading!

  4. #4
    Join Date
    Jan 2012
    Location
    Sydney, Australia
    Posts
    840
    Mentioned
    12 Post(s)
    Quoted
    345 Post(s)

    Default

    Quote Originally Posted by keasbey_nights View Post
    Thank you, and no worries on the forums being slow - will check out discord
    So it is fully doable to code for OSRS , using color ( recommended ) or reflection?

    Will start the installs and making my new RS account ready to go haha.
    Is there anything you guys can recommend specifically in the way of anti-ban?
    Obv. there's no perfect solution, but I would like to be able to get some time out of it account before the account gets burned lol.

    Again it's a new account so I'm not worried about losing wealth or anything ingame. Just curious.

    Thank you for reading!
    If you are keen to lean OSRS, use the Aerolib include.

    It is quite easy to grasp and is very powerful.

    Also to answer your previous question; you can bot OSRS in 100% color using Aerolib (which I personally prefer to do), although, you can also create scripts that use the reflection include only, or that utilize both.

    The benefit of using color is that you can run the script in the official OSRS client, or any of the third party clients on offer (such as OSBuddy), where as reflection requires the use of the SMART client.

    If you wanted to look at getting started in Aerolib/color scripting, see my signature for a few of the tutorials I have written. The first tutorial requires no previous knowledge of botting OSRS (although any previous coding, however basic, would be advantageous).
    There are also a few good tutorials that explain the different types, such as integers, booleans, strings, arrays etc that are certainly worth looking into.

    As Citrus mentioned above, feel free to ask questions in discord, or post any questions you have on the forums/this thread.

    Welcome to SRL

  5. #5
    Join Date
    Feb 2012
    Location
    Norway
    Posts
    968
    Mentioned
    142 Post(s)
    Quoted
    582 Post(s)

    Default

    As a core developer of the latest SRL for OSRS it is my duty to recommend it over AeroLib! @Flight

    To get started with SRL for OSRS you need the following:
    > Simba 1.2rc with leakfixes (drop the .exe in Simba folder, and use it instead of Simba.exe)
    > SRL for OSRS
    > RSWalker
    > A hamburger
    > A buckload of Redbull
    > A shovel, a mattock and a lantern as well (in case you give up).
    > And finally a fair bit of patience


    Tho, that said, there isn't any tutorials on SRL for OSRS. So you are on your own for a lot of it, but there is usually some help to get on the discord, and here on the forums, as long as you are willing to stick around and wait. There there is the source for SRL itself, and some scripts to look at, tho some may be slightly outdated, as the development of SRL has been quite rapid.
    Last edited by slacky; 01-03-2018 at 02:23 AM.
    !No priv. messages please

  6. #6
    Join Date
    Jan 2018
    Posts
    8
    Mentioned
    0 Post(s)
    Quoted
    6 Post(s)

    Default

    Quote Originally Posted by Dan the man View Post
    If you are keen to lean OSRS, use the Aerolib include.

    It is quite easy to grasp and is very powerful.

    Also to answer your previous question; you can bot OSRS in 100% color using Aerolib (which I personally prefer to do), although, you can also create scripts that use the reflection include only, or that utilize both.

    The benefit of using color is that you can run the script in the official OSRS client, or any of the third party clients on offer (such as OSBuddy), where as reflection requires the use of the SMART client.

    If you wanted to look at getting started in Aerolib/color scripting, see my signature for a few of the tutorials I have written. The first tutorial requires no previous knowledge of botting OSRS (although any previous coding, however basic, would be advantageous).
    There are also a few good tutorials that explain the different types, such as integers, booleans, strings, arrays etc that are certainly worth looking into.

    As Citrus mentioned above, feel free to ask questions in discord, or post any questions you have on the forums/this thread.

    Welcome to SRL
    Appreciate all the help folks.
    Will likely stick to the Aerolib include if I end up deciding to go OSRS with this
    ( Been busy today revamping my desk / workspace , haven't been on the interwebs much today. )

    Thank you to all, see you soon with some actual updates.

    Edit: Thank you for the explanation Slacky, but do to the lack of .. public support I suppose you could say,
    it doesn't seem like it would be easy for me to pick up on.

  7. #7
    Join Date
    Jan 2018
    Posts
    8
    Mentioned
    0 Post(s)
    Quoted
    6 Post(s)

    Default

    [Error] (2:1): Unable to register type TLayer at line 3
    Compiling failed.
    ^ going through the Aerolib download/install getting this error.
    I'm putting the aerolib folder ( the entire thing, not the contents ) into the includes.
    The taking the contents of the Plugin folder and putting it into the Plugin folder. When I do so it overwrites a few files,
    which I click yes to.

    Once I post this code ( as per the tutorial ) ;

    program new;
    {$i AeroLib/AeroLib.Simba}
    begin
    InitAL;
    end.
    I get the above error message.

    Any idea what's causing this/what I'm doing wrong?
    Going to run through the tutorial once or twice more to see if I'm making a stupid mistake.

    Also when I am going through the tutorials , they mention JRE 7.
    When I click the link to get that version Java tells me I'm trying to view an out of date version and it wont let me download it..
    help? wondering if thats the issue.
    Last edited by keasbey_nights; 01-09-2018 at 02:55 AM.

  8. #8
    Join Date
    Jan 2012
    Location
    Sydney, Australia
    Posts
    840
    Mentioned
    12 Post(s)
    Quoted
    345 Post(s)

    Default

    Quote Originally Posted by keasbey_nights View Post
    ^ going through the Aerolib download/install getting this error.
    I'm putting the aerolib folder ( the entire thing, not the contents ) into the includes.
    The taking the contents of the Plugin folder and putting it into the Plugin folder. When I do so it overwrites a few files,
    which I click yes to.

    Once I post this code ( as per the tutorial ) ;


    I get the above error message.

    Any idea what's causing this/what I'm doing wrong?
    Going to run through the tutorial once or twice more to see if I'm making a stupid mistake.

    Also when I am going through the tutorials , they mention JRE 7.
    When I click the link to get that version Java tells me I'm trying to view an out of date version and it wont let me download it..
    help? wondering if thats the issue.
    You need to install the latest version of Simba.

    Go to your Simba folder (C:\Simba) and change the name of Simba.exe to something like Simba Old.exe.

    Download this file: http://nala.villavu.com/downloads/ma...i386-win32.exe

    Place it in your Simba folder (C:\Simba) and rename it to simba.exe

    Should fix your issue.

  9. #9
    Join Date
    Jan 2018
    Posts
    8
    Mentioned
    0 Post(s)
    Quoted
    6 Post(s)

    Default

    Quote Originally Posted by Dan the man View Post
    You need to install the latest version of Simba.

    Go to your Simba folder (C:\Simba) and change the name of Simba.exe to something like Simba Old.exe.

    Download this file:

    Place it in your Simba folder (C:\Simba) and rename it to simba.exe

    Should fix your issue.
    I did that last night along with the other stuff I posted.
    Tried once more, no luck same error. That being said, although it sounds minute does it matter the name of my drive?
    Running laptop off an Extneral ( E:\Simba) drive - I can install to the internal C: drive instead.


    Edit:

    Just finished re-doing everything on my C:\Simba
    No luck, same error

    Any recommendations?
    Last edited by keasbey_nights; 01-09-2018 at 05:19 PM.

  10. #10
    Join Date
    Jan 2012
    Location
    Sydney, Australia
    Posts
    840
    Mentioned
    12 Post(s)
    Quoted
    345 Post(s)

  11. #11
    Join Date
    Jan 2018
    Posts
    8
    Mentioned
    0 Post(s)
    Quoted
    6 Post(s)

    Default

    Quote Originally Posted by Dan the man View Post
    Not sure. Might need to wait until @Flight reads the thread.
    Okay, well thanks for the feedback so far.
    Will wait patiently and keep trying different things tonight to see what happens.
    Just not exactly sure what I could be doing wrong
    1) DL Simba client
    2) DL Aerolib -> C:\simba\Includes
    3) DL plugins -> C:\Simba\Plugins ( overwrite old plugins )
    4) Replace Simba with current.exe
    5) Error

    I have made sure my SRL/SPS is up to date.

  12. #12
    Join Date
    Jan 2012
    Location
    Sydney, Australia
    Posts
    840
    Mentioned
    12 Post(s)
    Quoted
    345 Post(s)

    Default

    Quote Originally Posted by keasbey_nights View Post
    Okay, well thanks for the feedback so far.
    Will wait patiently and keep trying different things tonight to see what happens.
    Just not exactly sure what I could be doing wrong
    1) DL Simba client
    2) DL Aerolib -> C:\simba\Includes
    3) DL plugins -> C:\Simba\Plugins ( overwrite old plugins )
    4) Replace Simba with current.exe
    5) Error

    I have made sure my SRL/SPS is up to date.
    You have done all of the basic testing; like making sure you are using java 7 32bit or running as administrator etc?

  13. #13
    Join Date
    Jan 2018
    Posts
    8
    Mentioned
    0 Post(s)
    Quoted
    6 Post(s)

    Default

    Quote Originally Posted by Dan the man View Post
    You have done all of the basic testing; like making sure you are using java 7 32bit or running as administrator etc?
    I posted about the java up earlier in the thread.
    When I follow the link for Java 7, it says that it's out of date and re-directs me. There is no option to download.

  14. #14
    Join Date
    Jan 2012
    Location
    Sydney, Australia
    Posts
    840
    Mentioned
    12 Post(s)
    Quoted
    345 Post(s)

    Default

    Quote Originally Posted by keasbey_nights View Post
    I posted about the java up earlier in the thread.
    When I follow the link for Java 7, it says that it's out of date and re-directs me. There is no option to download.
    http://www.oracle.com/technetwork/ja...e7-521261.html



    Think this is the one I used a while ago?
    (Make sure you go to the JRE panel not the JDK)

  15. #15
    Join Date
    Jan 2012
    Location
    Sydney, Australia
    Posts
    840
    Mentioned
    12 Post(s)
    Quoted
    345 Post(s)

  16. #16
    Join Date
    Jan 2018
    Posts
    8
    Mentioned
    0 Post(s)
    Quoted
    6 Post(s)

    Default

    Alright, thank you so much for posting that.
    Uninstalled JRE 8u144, Installed JRE7u80 ,
    restarting computer now to see if we can make some headway in this.

  17. #17
    Join Date
    Aug 2007
    Location
    Colorado
    Posts
    7,318
    Mentioned
    264 Post(s)
    Quoted
    1394 Post(s)

    Default

    Quote Originally Posted by slacky View Post
    As a core developer of the latest SRL for OSRS it is my duty to recommend it over AeroLib! @Flight
    Ouch!

    Quote Originally Posted by keasbey_nights View Post
    Okay, well thanks for the feedback so far.
    Will wait patiently and keep trying different things tonight to see what happens.
    Just not exactly sure what I could be doing wrong
    1) DL Simba client
    2) DL Aerolib -> C:\simba\Includes
    3) DL plugins -> C:\Simba\Plugins ( overwrite old plugins )
    4) Replace Simba with current.exe
    5) Error

    I have made sure my SRL/SPS is up to date.
    After following Dan the man's most recent advice on his post above, which error are you getting when trying to run an AeroLib-based script?

    I just fresh installed Simba myself on a new laptop as my previous one bit the dust. Everything started up fine for me, in fact the only installation I had to do was 32-bit Java; I'm not even running Simba as administrator. So if you could give me an update on which error you're getting now I'll be happy to assist you from there.

    Current project:
    [Scripts / AeroLib Rev. 2]


    Did you know?
    J1407b, dubbed "Saturn on steriods", has a ring system 200 times larger than Saturn's own rings.
    #teampixel

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •